forked from brl/citadel
48 lines
1.5 KiB
Diff
48 lines
1.5 KiB
Diff
From a8f79e6e347a5d884ea8d351631a6f6e899060cc Mon Sep 17 00:00:00 2001
|
|
From: Arjan van de Ven <arjan@linux.intel.com>
|
|
Date: Thu, 2 Jun 2016 23:36:32 -0500
|
|
Subject: [PATCH 116/126] Initialize ata before graphics
|
|
|
|
ATA init is the long pole in the boot process, and its asynchronous.
|
|
move the graphics init after it so that ata and graphics initialize
|
|
in parallel
|
|
---
|
|
drivers/Makefile | 11 ++++++-----
|
|
1 file changed, 6 insertions(+), 5 deletions(-)
|
|
|
|
diff --git a/drivers/Makefile b/drivers/Makefile
|
|
index d242d3514d30..b73656e2caa0 100644
|
|
--- a/drivers/Makefile
|
|
+++ b/drivers/Makefile
|
|
@@ -61,14 +61,9 @@ obj-y += char/
|
|
# iommu/ comes before gpu as gpu are using iommu controllers
|
|
obj-$(CONFIG_IOMMU_SUPPORT) += iommu/
|
|
|
|
-# gpu/ comes after char for AGP vs DRM startup and after iommu
|
|
-obj-y += gpu/
|
|
|
|
obj-$(CONFIG_CONNECTOR) += connector/
|
|
|
|
-# i810fb and intelfb depend on char/agp/
|
|
-obj-$(CONFIG_FB_I810) += video/fbdev/i810/
|
|
-obj-$(CONFIG_FB_INTEL) += video/fbdev/intelfb/
|
|
|
|
obj-$(CONFIG_PARPORT) += parport/
|
|
obj-$(CONFIG_NVM) += lightnvm/
|
|
@@ -82,6 +77,12 @@ obj-$(CONFIG_IDE) += ide/
|
|
obj-$(CONFIG_SCSI) += scsi/
|
|
obj-y += nvme/
|
|
obj-$(CONFIG_ATA) += ata/
|
|
+
|
|
+# gpu/ comes after char for AGP vs DRM startup and after iommu
|
|
+obj-y += gpu/
|
|
+# i810fb and intelfb depend on char/agp/
|
|
+obj-$(CONFIG_FB_I810) += video/fbdev/i810/
|
|
+obj-$(CONFIG_FB_INTEL) += video/fbdev/intelfb/
|
|
obj-$(CONFIG_TARGET_CORE) += target/
|
|
obj-$(CONFIG_MTD) += mtd/
|
|
obj-$(CONFIG_SPI) += spi/
|
|
--
|
|
2.15.0
|
|
|