forked from brl/citadel
Bruce Leidl
be34ea65f3
- removed layers meta-rust and meta-clang - added new dependencies to Makefile - changed override syntax across all recipe files - updated conf files from hardknott to kirkstone - SRC_URI git URLS fixed to always include branch and protocol - LICENSE fields updated with new naming convention - updated citadel-tools dependencies - upgraded mozjs to mozjs-91 No longer needed because poky includes newer version (or new enough): - glib-2.0 - libgudev - xorgproto - libxfixes - libinput - wayland-protocols - vte
30 lines
815 B
Diff
30 lines
815 B
Diff
From 9e37248870b2b955293754933c789ca00bca06ef Mon Sep 17 00:00:00 2001
|
|
From: Alexander Kanavin <alex@linutronix.de>
|
|
Date: Fri, 1 Oct 2021 13:00:24 +0200
|
|
Subject: [PATCH] Cargo.toml: do not abort on panic
|
|
|
|
OE's rust is configured to unwind, and this setting clashes with it/
|
|
|
|
Upstream-Status: Inappropriate [oe-core specific]
|
|
Signed-off-by: Alexander Kanavin <alex@linutronix.de>
|
|
---
|
|
Cargo.toml | 3 +--
|
|
1 file changed, 1 insertion(+), 2 deletions(-)
|
|
|
|
--- a/Cargo.toml
|
|
+++ b/Cargo.toml
|
|
@@ -51,13 +51,11 @@ opt-level = 1
|
|
rpath = false
|
|
lto = false
|
|
debug-assertions = true
|
|
-panic = "abort"
|
|
|
|
[profile.release]
|
|
opt-level = 2
|
|
rpath = false
|
|
debug-assertions = false
|
|
-panic = "abort"
|
|
|
|
# Optimize build dependencies, because bindgen and proc macros / style
|
|
# compilation take more to run than to build otherwise.
|