forked from brl/citadel
Bruce Leidl
4c3baa433b
Updated Recipes * dash-to-panel 40 * dconf 0.38.0 * gdm 3.38.0 * glib 2.66.1 * gjs 1.66.0 * gnome-autoar 0.2.4 * gnome-backgrounds 3.38.0 * gnome-bluetooth 3.34.3 * gnome-control-center 3.38.1 * gnome-screenshot 3.38.0 * gnome-shell 3.38.1 * gnome-session 3.38.0 * gnome-settings-daemon 3.38.0 * gnome-terminal 3.38.0 * gnome-usage 3.38.0 * graphene 1.10.2 * gsettings-desktop-schema 3.38.0 * gvfs 1.46.1 * iwd 1.9 * libgee 0.20.3 * libgtop 2.40.0 * libgweather 3.36.1 * mkpasswd 5.5.7 * mozjs 78.0.1 * mutter 3.38.1 * nautilus 3.38.1 * networkmanager 1.26.4 * polkit 0.118 * tracker 3.0.1 * vte 0.62.0 Removed because recipes exist in poky with adequate version * atk, at-spi * clutter * clutter-gtk * cogl * ell * gcr * itstool * libinput * pango Other removed recipes * systemd-initrd No longer using a separate systemd recipe for initramfs * caribou What even is this * gnome-tweaks Not used * mozjs Polkit no longer requires an ancient mozjs * mozjs68 Upgraded to mozjs78
45 lines
1.4 KiB
Diff
45 lines
1.4 KiB
Diff
From 2701905e689cf7c1ee7ca2d116f20b5bbc146431 Mon Sep 17 00:00:00 2001
|
|
From: Wenzong Fan <wenzong.fan@windriver.com>
|
|
Date: Sat, 7 Mar 2020 08:34:02 -0800
|
|
Subject: [PATCH] Fix nss multilib build on openSUSE 11.x 32bit
|
|
|
|
While building lib64-nss on openSUSE 11.x 32bit, the nsinstall will
|
|
fail with error:
|
|
|
|
* nsinstall.c:1:0: sorry, unimplemented: 64-bit mode not compiled
|
|
|
|
It caused by the '-m64' option which passed to host gcc.
|
|
|
|
The nsinstall was built first while nss starting to build, it only runs
|
|
on host to install built files, it doesn't need any cross-compling or
|
|
multilib build options. Just clean the ARCHFLAG and LDFLAGS to fix this
|
|
error.
|
|
|
|
Upstream-Status: Pending
|
|
|
|
Signed-off-by: Wenzong Fan <wenzong.fan@windriver.com>
|
|
===================================================
|
|
|
|
---
|
|
nss/coreconf/nsinstall/Makefile | 7 +++++++
|
|
1 file changed, 7 insertions(+)
|
|
|
|
diff --git a/nss/coreconf/nsinstall/Makefile b/nss/coreconf/nsinstall/Makefile
|
|
index 08dfbc2..e97fb5f 100644
|
|
--- a/nss/coreconf/nsinstall/Makefile
|
|
+++ b/nss/coreconf/nsinstall/Makefile
|
|
@@ -18,6 +18,13 @@ INTERNAL_TOOLS = 1
|
|
|
|
include $(DEPTH)/coreconf/config.mk
|
|
|
|
+# nsinstall is unfit for cross-compiling/multilib-build since it was
|
|
+# always run on local host to install built files. This change intends
|
|
+# to clean the '-m64' from ARCHFLAG and LDFLAGS.
|
|
+ARCHFLAG =
|
|
+LDFLAGS =
|
|
+# CFLAGS =
|
|
+
|
|
ifeq (,$(filter-out OS2 WIN%,$(OS_TARGET)))
|
|
PROGRAM =
|
|
TARGETS =
|