forked from brl/citadel
Bruce Leidl
4c3baa433b
Updated Recipes * dash-to-panel 40 * dconf 0.38.0 * gdm 3.38.0 * glib 2.66.1 * gjs 1.66.0 * gnome-autoar 0.2.4 * gnome-backgrounds 3.38.0 * gnome-bluetooth 3.34.3 * gnome-control-center 3.38.1 * gnome-screenshot 3.38.0 * gnome-shell 3.38.1 * gnome-session 3.38.0 * gnome-settings-daemon 3.38.0 * gnome-terminal 3.38.0 * gnome-usage 3.38.0 * graphene 1.10.2 * gsettings-desktop-schema 3.38.0 * gvfs 1.46.1 * iwd 1.9 * libgee 0.20.3 * libgtop 2.40.0 * libgweather 3.36.1 * mkpasswd 5.5.7 * mozjs 78.0.1 * mutter 3.38.1 * nautilus 3.38.1 * networkmanager 1.26.4 * polkit 0.118 * tracker 3.0.1 * vte 0.62.0 Removed because recipes exist in poky with adequate version * atk, at-spi * clutter * clutter-gtk * cogl * ell * gcr * itstool * libinput * pango Other removed recipes * systemd-initrd No longer using a separate systemd recipe for initramfs * caribou What even is this * gnome-tweaks Not used * mozjs Polkit no longer requires an ancient mozjs * mozjs68 Upgraded to mozjs78
48 lines
1.5 KiB
Diff
48 lines
1.5 KiB
Diff
From 8b67c22b057e158f61c9fdd5b01f37195c6f5ca4 Mon Sep 17 00:00:00 2001
|
|
From: Alexander Kanavin <alex.kanavin@gmail.com>
|
|
Date: Wed, 18 Dec 2019 12:29:50 +0100
|
|
Subject: [PATCH] freebl: add a configure option to disable ARM HW crypto
|
|
|
|
Not all current hardware supports it, particularly anything
|
|
prior to armv8 does not.
|
|
|
|
Upstream-Status: Pending
|
|
Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com>
|
|
|
|
---
|
|
nss/lib/freebl/Makefile | 4 ++++
|
|
nss/lib/freebl/gcm.c | 2 ++
|
|
2 files changed, 6 insertions(+)
|
|
|
|
--- a/nss/lib/freebl/Makefile
|
|
+++ b/nss/lib/freebl/Makefile
|
|
@@ -126,6 +126,8 @@ else
|
|
endif
|
|
endif
|
|
ifdef NS_USE_GCC
|
|
+ifdef NSS_USE_ARM_HW_CRYPTO
|
|
+ DEFINES += -DNSS_USE_ARM_HW_CRYPTO
|
|
ifeq ($(CPU_ARCH),aarch64)
|
|
DEFINES += -DUSE_HW_AES -DUSE_HW_SHA1 -DUSE_HW_SHA2
|
|
EXTRA_SRCS += aes-armv8.c gcm-aarch64.c sha1-armv8.c sha256-armv8.c
|
|
@@ -150,6 +152,7 @@ endif
|
|
endif
|
|
endif
|
|
endif
|
|
+endif
|
|
|
|
ifeq ($(OS_TARGET),OSF1)
|
|
DEFINES += -DMP_ASSEMBLY_MULTIPLY -DMP_NO_MP_WORD
|
|
--- a/nss/lib/freebl/gcm.c
|
|
+++ b/nss/lib/freebl/gcm.c
|
|
@@ -21,7 +21,9 @@
|
|
/* old gcc doesn't support some poly64x2_t intrinsic */
|
|
#if defined(__aarch64__) && defined(IS_LITTLE_ENDIAN) && \
|
|
(defined(__clang__) || defined(__GNUC__) && __GNUC__ > 6)
|
|
+# ifdef NSS_USE_ARM_HW_CRYPTO
|
|
#define USE_ARM_GCM
|
|
+# endif
|
|
#elif defined(__arm__) && defined(IS_LITTLE_ENDIAN) && \
|
|
!defined(NSS_DISABLE_ARM32_NEON)
|
|
/* We don't test on big endian platform, so disable this on big endian. */
|