1
0
forked from brl/citadel
citadel/meta-gnome/recipes-gnome/pipewire/pipewire-0.2_git.bb
Bruce Leidl 4831a46764 GNOME upgrade to 46.0
Recipes updated:

  adwaita-icon-theme             43 --> 46.0
  cairomm                    1.12.0 --> 1.18
  gdm                          42.0 --> 45.0
  glibmm                     2.62.0 --> 2.78.0
  gjs                       1.77.90 --> 1.80.0
  gnome-backgrounds            45.0 --> 46.0
  gnome-bluetooth              42.4 --> 46.0
  gnome-control-center         45.0 --> 46.0
  gnome-disk-utility           42.0 --> 46.0
  gnome-session                42.0 --> 46.0
  gnome-settings-daemon        45.0 --> 46.0
  gnome-shell                  45.0 --> 46.0
  gnome-system-monitor         42.0 --> 46.0
  gsettings-desktop-schemas    45.0 --> 46.0
  gtk4                       4.12.1 --> 4.14.1
  gvfs                       1.50.2 --> 1.54.0
  libadwaita                  1.4.0 --> 1.5.0
  libgtop                    2.40.0 --> 2.41.3
  libgweather4                4.2.0 --> 4.4.2
  libwacom                     0.26 --> 2.8.0
  mutter                       45.0 --> 46.0
  pangomm                    2.46.2 --> 2.50.1

New recipes added:

  pipewire 1.0.4
  wireplumber 0.5.0
  doxygen 1.9.3
  gcr 4.2.0
  rtkit 0.13
  libopus 1.5.1
  libjxl 0.10.2
  wayland
  gtkmm4  4.14.0
2024-05-08 11:00:03 -04:00

65 lines
1.6 KiB
BlitzBasic

SUMMARY = "Multimedia processing server for Linux"
HOMEPAGE = "https://pipewire.org"
SECTION = "multimedia"
LICENSE = "LGPL-2.1-only"
LIC_FILES_CHKSUM = " \
file://LICENSE;md5=d8153c6e65986f862a0550ca74a3ed73 \
file://LGPL;md5=2d5025d4aa3495befef8f17206a5b0a1 \
"
DEPENDS = "alsa-lib dbus udev"
SRCREV = "14c11c0fe4d366bad4cfecdee97b6652ff9ed63d"
PV = "0.2.7"
SRC_URI = "git://github.com/PipeWire/pipewire;branch=master;protocol=https"
S = "${WORKDIR}/git"
inherit meson pkgconfig systemd manpages
PACKAGECONFIG ??= "\
${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)} \
gstreamer \
"
PACKAGECONFIG[systemd] = "-Dsystemd=true,-Dsystemd=false,systemd"
PACKAGECONFIG[gstreamer] = "-Dgstreamer=enabled,-Dgstreamer=disabled,glib-2.0 gstreamer1.0 gstreamer1.0-plugins-base"
PACKAGECONFIG[manpages] = "-Dman=true,-Dman=false,libxml-parser-perl-native"
PACKAGES =+ "\
${PN}-spa-plugins \
${PN}-alsa \
${PN}-config \
gstreamer1.0-${PN} \
lib${PN} \
lib${PN}-modules \
"
RDEPENDS:lib${PN} += "lib${PN}-modules ${PN}-spa-plugins"
FILES:${PN} = "\
${sysconfdir}/pipewire/pipewire.conf \
${bindir}/pipewire* \
${systemd_user_unitdir}/* \
"
FILES:lib${PN} = "\
${libdir}/libpipewire-*.so.* \
"
FILES:lib${PN}-modules = "\
${libdir}/pipewire-*/* \
"
FILES:${PN}-spa-plugins = "\
${bindir}/spa-* \
${libdir}/spa/* \
"
FILES:${PN}-alsa = "\
${libdir}/alsa-lib/* \
${datadir}/alsa/alsa.conf.d/50-pipewire.conf \
"
FILES:gstreamer1.0-${PN} = "\
${libdir}/gstreamer-1.0/* \
"
CONFFILES:${PN} = "\
${sysconfdir}/pipewire/pipewire.conf \
"