1
0
forked from brl/citadel
citadel/meta-gnome/recipes-gnome/mutter/mutter_46.0.bb

100 lines
2.4 KiB
BlitzBasic

SUMMARY = "Window and compositing manager based on Clutter"
LICENSE = "GPL-2.0-only"
LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
DEPENDS = " \
xserver-xorg-cvt-native \
libsm \
virtual/libx11 \
libxi \
glib-2.0 \
libwacom \
xcomposite \
libinput \
libei \
libcanberra \
mesa \
upower \
xwayland \
gtk4 \
gdk-pixbuf \
cairo \
pango \
gsettings-desktop-schemas \
json-glib \
gnome-desktop \
gnome-settings-daemon \
libxtst \
libxkbfile \
startup-notification \
xinerama \
graphene \
graphene-native \
wayland-protocols \
wayland-native \
gobject-introspection \
gobject-introspection-native \
"
RDEPENDS:${PN} += " xwayland zenity"
SRCREV = "ab32580b4c916914aec8429b3d4d68fef1dd583e"
EXTERNAL_TREE_VAR="CITADEL_MUTTER_PATH"
GIT_URI = "git://git.subgraph.com/brl/mutter.git;branch=citadel-46.0;protocol=https"
inherit gnomebase gsettings gobject-introspection gettext upstream-version-is-even features_check external-tree
# x11 is still mandatory - see meson.build
REQUIRED_DISTRO_FEATURES = "x11 systemd"
# systemd can be replaced by libelogind (not available atow - make systemd
# mandatory distro feature)
LOGIND ?= "systemd"
EXTRA_OEMESON += " \
-Dremote_desktop=false \
-Dtests=false \
-Dprofiler=false \
-Dcogl_tests=false \
-Dlibwacom=true \
-Dxwayland_initfd=disabled \
-Dxwayland_path=/usr/bin/Xwayland \
-Dgles2_libname=libGLESv2.so.2 \
"
MUTTER_API_NAME = "mutter-14"
do_install:append() {
# Add gir links in standard paths. That makes dependents life much easier
# to find them
install -d ${D}${datadir}/gir-1.0
for gir_full in `find ${D}${libdir}/${MUTTER_API_NAME} -name '*.gir'`; do
gir=`basename "$gir_full"`
ln -sr "${D}${libdir}/${MUTTER_API_NAME}/$gir" "${D}${datadir}/gir-1.0/$gir"
done
}
PACKAGES =+ "${PN}-tests"
FILES:${PN} += " \
${datadir}/gnome-control-center \
${libdir}/${MUTTER_API_NAME}/lib*${SOLIBS} \
${libdir}/${MUTTER_API_NAME}/*.typelib \
${libdir}/${MUTTER_API_NAME}/plugins \
"
FILES:${PN}-tests += " \
${datadir}/installed-tests \
${datadir}/${MUTTER_API_NAME}/tests \
${libexecdir}/installed-tests/${MUTTER_API_NAME} \
"
FILES:${PN}-dev += " \
${libdir}/${MUTTER_API_NAME}/*.gir \
${libdir}/${MUTTER_API_NAME}/lib*.so \
"