1
0
forked from brl/citadel
citadel/meta-citadel/recipes-support/nnn/nnn_4.5.bb
Bruce Leidl be34ea65f3 upgrade poky layer to 'kirkstone' release 4.0.1
- removed layers meta-rust and meta-clang
- added new dependencies to Makefile
- changed override syntax across all recipe files
- updated conf files from hardknott to kirkstone
- SRC_URI git URLS fixed to always include branch and protocol
- LICENSE fields updated with new naming convention
- updated citadel-tools dependencies

- upgraded mozjs to mozjs-91

No longer needed because poky includes newer version (or new enough):

- glib-2.0
- libgudev
- xorgproto
- libxfixes
- libinput
- wayland-protocols
- vte
2022-05-28 11:20:07 -04:00

23 lines
554 B
BlitzBasic

DESCRIPTION = "Tiny, lightning fast, feature-packed file manager"
SUMMARY = "Small command line file manager"
HOMEPAGE = "https://github.com/jarun/nnn"
SECTION = "base"
LICENSE = "BSD-2-Clause"
LIC_FILES_CHKSUM = "file://LICENSE;md5=ee18574190d1b9d7ce45445955af2c9b"
DEPENDS = "ncurses readline"
inherit pkgconfig
SRCREV = "3f58f6111c95a38f2bfbdde92c42bf54edeb5927"
SRC_URI = "git://github.com/jarun/nnn.git;protocol=https;branch=master"
S = "${WORKDIR}/git"
EXTRA_OEMAKE = "'PREFIX=/usr'"
do_install () {
oe_runmake 'DESTDIR=${D}' install
}