1
0
forked from brl/citadel
citadel/meta-citadel/recipes-support/nano/nano_5.8.bb
Bruce Leidl be34ea65f3 upgrade poky layer to 'kirkstone' release 4.0.1
- removed layers meta-rust and meta-clang
- added new dependencies to Makefile
- changed override syntax across all recipe files
- updated conf files from hardknott to kirkstone
- SRC_URI git URLS fixed to always include branch and protocol
- LICENSE fields updated with new naming convention
- updated citadel-tools dependencies

- upgraded mozjs to mozjs-91

No longer needed because poky includes newer version (or new enough):

- glib-2.0
- libgudev
- xorgproto
- libxfixes
- libinput
- wayland-protocols
- vte
2022-05-28 11:20:07 -04:00

23 lines
743 B
BlitzBasic

SUMMARY = "Small and friendly console text editor"
DESCRIPTION = "GNU nano (Nano's ANOther editor, or \
Not ANOther editor) is an enhanced clone of the \
Pico text editor."
HOMEPAGE = "http://www.nano-editor.org/"
SECTION = "console/utils"
LICENSE = "GPL-3.0-only"
LIC_FILES_CHKSUM = "file://COPYING;md5=f27defe1e96c2e1ecd4e0c9be8967949"
DEPENDS = "ncurses file"
RDEPENDS:${PN} = "ncurses-terminfo-base"
PV_MAJOR = "${@d.getVar('PV').split('.')[0]}"
SRC_URI = "https://nano-editor.org/dist/v${PV_MAJOR}/nano-${PV}.tar.xz"
SRC_URI[sha256sum] = "e43b63db2f78336e2aa123e8d015dbabc1720a15361714bfd4b1bb4e5e87768c"
UPSTREAM_CHECK_URI = "https://ftp.gnu.org/gnu/nano"
inherit autotools gettext pkgconfig
PACKAGECONFIG[tiny] = "--enable-tiny,"