Bruce Leidl
4c3baa433b
Updated Recipes * dash-to-panel 40 * dconf 0.38.0 * gdm 3.38.0 * glib 2.66.1 * gjs 1.66.0 * gnome-autoar 0.2.4 * gnome-backgrounds 3.38.0 * gnome-bluetooth 3.34.3 * gnome-control-center 3.38.1 * gnome-screenshot 3.38.0 * gnome-shell 3.38.1 * gnome-session 3.38.0 * gnome-settings-daemon 3.38.0 * gnome-terminal 3.38.0 * gnome-usage 3.38.0 * graphene 1.10.2 * gsettings-desktop-schema 3.38.0 * gvfs 1.46.1 * iwd 1.9 * libgee 0.20.3 * libgtop 2.40.0 * libgweather 3.36.1 * mkpasswd 5.5.7 * mozjs 78.0.1 * mutter 3.38.1 * nautilus 3.38.1 * networkmanager 1.26.4 * polkit 0.118 * tracker 3.0.1 * vte 0.62.0 Removed because recipes exist in poky with adequate version * atk, at-spi * clutter * clutter-gtk * cogl * ell * gcr * itstool * libinput * pango Other removed recipes * systemd-initrd No longer using a separate systemd recipe for initramfs * caribou What even is this * gnome-tweaks Not used * mozjs Polkit no longer requires an ancient mozjs * mozjs68 Upgraded to mozjs78
43 lines
1.7 KiB
Diff
43 lines
1.7 KiB
Diff
From c5b2c6327f3692ed07bf8d212123e0bf08485722 Mon Sep 17 00:00:00 2001
|
|
From: Khem Raj <raj.khem@gmail.com>
|
|
Date: Sat, 7 Mar 2020 08:34:02 -0800
|
|
Subject: [PATCH] nss,nspr: Add recipes
|
|
|
|
clang 3.9 add this warning to rightly flag undefined
|
|
behavior, we relegate this to be just a warning instead
|
|
of error and keep the behavior as it was. Right fix would
|
|
be to not pass enum to the function with variadic arguments
|
|
as last named argument
|
|
|
|
Fixes errors like
|
|
ocsp.c:2220:22: error: passing an object that undergoes default argument promotion to 'va_start' has undefined behavior [-Werror,-Wvarargs]
|
|
va_start(ap, responseType0);
|
|
^
|
|
ocsp.c:2200:43: note: parameter of type 'SECOidTag' is declared here
|
|
SECOidTag responseType0, ...)
|
|
|
|
see
|
|
https://www.securecoding.cert.org/confluence/display/cplusplus/EXP58-CPP.+Pass+an+object+of+the+correct+type+to+va_start
|
|
for more details
|
|
|
|
Signed-off-by: Khem Raj <raj.khem@gmail.com>
|
|
Upstream-Status: Pending
|
|
|
|
---
|
|
nss/coreconf/Werror.mk | 2 +-
|
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
|
|
diff --git a/nss/coreconf/Werror.mk b/nss/coreconf/Werror.mk
|
|
index a569a49..687fe58 100644
|
|
--- a/nss/coreconf/Werror.mk
|
|
+++ b/nss/coreconf/Werror.mk
|
|
@@ -56,7 +56,7 @@ ifndef WARNING_CFLAGS
|
|
ifdef CC_IS_CLANG
|
|
# -Qunused-arguments : clang objects to arguments that it doesn't understand
|
|
# and fixing this would require rearchitecture
|
|
- WARNING_CFLAGS += -Qunused-arguments
|
|
+ WARNING_CFLAGS += -Qunused-arguments -Wno-error=varargs
|
|
# -Wno-parentheses-equality : because clang warns about macro expansions
|
|
WARNING_CFLAGS += $(call disable_warning,parentheses-equality)
|
|
ifdef BUILD_OPT
|