Bruce Leidl
4c3baa433b
Updated Recipes * dash-to-panel 40 * dconf 0.38.0 * gdm 3.38.0 * glib 2.66.1 * gjs 1.66.0 * gnome-autoar 0.2.4 * gnome-backgrounds 3.38.0 * gnome-bluetooth 3.34.3 * gnome-control-center 3.38.1 * gnome-screenshot 3.38.0 * gnome-shell 3.38.1 * gnome-session 3.38.0 * gnome-settings-daemon 3.38.0 * gnome-terminal 3.38.0 * gnome-usage 3.38.0 * graphene 1.10.2 * gsettings-desktop-schema 3.38.0 * gvfs 1.46.1 * iwd 1.9 * libgee 0.20.3 * libgtop 2.40.0 * libgweather 3.36.1 * mkpasswd 5.5.7 * mozjs 78.0.1 * mutter 3.38.1 * nautilus 3.38.1 * networkmanager 1.26.4 * polkit 0.118 * tracker 3.0.1 * vte 0.62.0 Removed because recipes exist in poky with adequate version * atk, at-spi * clutter * clutter-gtk * cogl * ell * gcr * itstool * libinput * pango Other removed recipes * systemd-initrd No longer using a separate systemd recipe for initramfs * caribou What even is this * gnome-tweaks Not used * mozjs Polkit no longer requires an ancient mozjs * mozjs68 Upgraded to mozjs78
47 lines
1.2 KiB
Diff
47 lines
1.2 KiB
Diff
From 8cea16e7550ae14494fbb3a8fe9f5452e6bd1407 Mon Sep 17 00:00:00 2001
|
|
From: Alexander Kanavin <alex.kanavin@gmail.com>
|
|
Date: Wed, 22 Feb 2017 11:36:11 +0200
|
|
Subject: [PATCH] nss: fix support cross compiling
|
|
|
|
Let some make variables be assigned from outside makefile.
|
|
|
|
Upstream-Status: Inappropriate [configuration]
|
|
Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
|
|
Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com>
|
|
|
|
---
|
|
nss/coreconf/arch.mk | 2 +-
|
|
nss/lib/freebl/Makefile | 6 ++++++
|
|
2 files changed, 7 insertions(+), 1 deletion(-)
|
|
|
|
diff --git a/nss/coreconf/arch.mk b/nss/coreconf/arch.mk
|
|
index 790372d..2563134 100644
|
|
--- a/nss/coreconf/arch.mk
|
|
+++ b/nss/coreconf/arch.mk
|
|
@@ -30,7 +30,7 @@ OS_TEST := $(shell uname -m)
|
|
ifeq ($(OS_TEST),i86pc)
|
|
OS_RELEASE := $(shell uname -r)_$(OS_TEST)
|
|
else
|
|
- OS_RELEASE := $(shell uname -r)
|
|
+ OS_RELEASE ?= $(shell uname -r)
|
|
endif
|
|
|
|
#
|
|
diff --git a/nss/lib/freebl/Makefile b/nss/lib/freebl/Makefile
|
|
index 52d827c..f99f769 100644
|
|
--- a/nss/lib/freebl/Makefile
|
|
+++ b/nss/lib/freebl/Makefile
|
|
@@ -36,6 +36,12 @@ ifdef USE_64
|
|
DEFINES += -DNSS_USE_64
|
|
endif
|
|
|
|
+ifeq ($(OS_TEST),mips)
|
|
+ifndef USE_64
|
|
+ DEFINES += -DNS_PTR_LE_32
|
|
+endif
|
|
+endif
|
|
+
|
|
ifdef USE_ABI32_FPU
|
|
DEFINES += -DNSS_USE_ABI32_FPU
|
|
endif
|