Bruce Leidl
4c3baa433b
Updated Recipes * dash-to-panel 40 * dconf 0.38.0 * gdm 3.38.0 * glib 2.66.1 * gjs 1.66.0 * gnome-autoar 0.2.4 * gnome-backgrounds 3.38.0 * gnome-bluetooth 3.34.3 * gnome-control-center 3.38.1 * gnome-screenshot 3.38.0 * gnome-shell 3.38.1 * gnome-session 3.38.0 * gnome-settings-daemon 3.38.0 * gnome-terminal 3.38.0 * gnome-usage 3.38.0 * graphene 1.10.2 * gsettings-desktop-schema 3.38.0 * gvfs 1.46.1 * iwd 1.9 * libgee 0.20.3 * libgtop 2.40.0 * libgweather 3.36.1 * mkpasswd 5.5.7 * mozjs 78.0.1 * mutter 3.38.1 * nautilus 3.38.1 * networkmanager 1.26.4 * polkit 0.118 * tracker 3.0.1 * vte 0.62.0 Removed because recipes exist in poky with adequate version * atk, at-spi * clutter * clutter-gtk * cogl * ell * gcr * itstool * libinput * pango Other removed recipes * systemd-initrd No longer using a separate systemd recipe for initramfs * caribou What even is this * gnome-tweaks Not used * mozjs Polkit no longer requires an ancient mozjs * mozjs68 Upgraded to mozjs78
101 lines
3.5 KiB
Diff
101 lines
3.5 KiB
Diff
From 12fd2083761c1d432a2b505a210d1289b2b1624f Mon Sep 17 00:00:00 2001
|
|
From: David McKinney <mckinney@subgraph.com>
|
|
Date: Wed, 8 Jul 2020 14:07:06 +0000
|
|
Subject: [PATCH] Remove calendar server, fix build
|
|
|
|
---
|
|
js/dbusServices/meson.build | 2 +-
|
|
meson.build | 10 +++++-----
|
|
src/meson.build | 2 +-
|
|
subprojects/extensions-app/js/meson.build | 2 +-
|
|
subprojects/extensions-app/meson.build | 2 +-
|
|
5 files changed, 9 insertions(+), 9 deletions(-)
|
|
|
|
diff --git a/js/dbusServices/meson.build b/js/dbusServices/meson.build
|
|
index 2f047bb..6484cdc 100644
|
|
--- a/js/dbusServices/meson.build
|
|
+++ b/js/dbusServices/meson.build
|
|
@@ -26,7 +26,7 @@ foreach service, dir : dbus_services
|
|
|
|
serviceconf = configuration_data()
|
|
serviceconf.set('service', service)
|
|
- serviceconf.set('gjs', gjs.path())
|
|
+ serviceconf.set('gjs', gjs)
|
|
serviceconf.set('pkgdatadir', pkgdatadir)
|
|
|
|
configure_file(
|
|
diff --git a/meson.build b/meson.build
|
|
index d86879a..c23ab0b 100644
|
|
--- a/meson.build
|
|
+++ b/meson.build
|
|
@@ -18,8 +18,8 @@ cogl_pc = 'mutter-cogl-' + mutter_api_version
|
|
cogl_pango_pc = 'mutter-cogl-pango-' + mutter_api_version
|
|
libmutter_pc = 'libmutter-' + mutter_api_version
|
|
|
|
-ecal_req = '>= 3.33.1'
|
|
-eds_req = '>= 3.33.1'
|
|
+#ecal_req = '>= 3.33.1'
|
|
+#eds_req = '>= 3.33.1'
|
|
gcr_req = '>= 3.7.5'
|
|
gio_req = '>= 2.56.0'
|
|
gi_req = '>= 1.49.1'
|
|
@@ -71,8 +71,8 @@ else
|
|
endif
|
|
|
|
atk_bridge_dep = dependency('atk-bridge-2.0')
|
|
-ecal_dep = dependency('libecal-2.0', version: ecal_req)
|
|
-eds_dep = dependency('libedataserver-1.2', version: eds_req)
|
|
+#ecal_dep = dependency('libecal-2.0', version: ecal_req)
|
|
+#eds_dep = dependency('libedataserver-1.2', version: eds_req)
|
|
gcr_dep = dependency('gcr-base-3', version: gcr_req)
|
|
gdk_x11_dep = dependency('gdk-x11-3.0')
|
|
gdk_pixbuf_dep = dependency('gdk-pixbuf-2.0')
|
|
@@ -134,7 +134,7 @@ endif
|
|
mutter_typelibdir = mutter_dep.get_pkgconfig_variable('typelibdir')
|
|
python = find_program('python3')
|
|
sassc = find_program('sassc')
|
|
-gjs = find_program('gjs')
|
|
+gjs = '/usr/bin/gjs'
|
|
|
|
cc = meson.get_compiler('c')
|
|
|
|
diff --git a/src/meson.build b/src/meson.build
|
|
index a7c56bb..3118e67 100644
|
|
--- a/src/meson.build
|
|
+++ b/src/meson.build
|
|
@@ -1,7 +1,7 @@
|
|
service_data = configuration_data()
|
|
service_data.set('libexecdir', libexecdir)
|
|
|
|
-subdir('calendar-server')
|
|
+#subdir('calendar-server')
|
|
subdir('hotplug-sniffer')
|
|
subdir('st')
|
|
subdir('tray')
|
|
diff --git a/subprojects/extensions-app/js/meson.build b/subprojects/extensions-app/js/meson.build
|
|
index a378a7e..f2a37ba 100644
|
|
--- a/subprojects/extensions-app/js/meson.build
|
|
+++ b/subprojects/extensions-app/js/meson.build
|
|
@@ -5,7 +5,7 @@ launcherconf.set('PACKAGE_VERSION', meson.project_version())
|
|
launcherconf.set('prefix', prefix)
|
|
launcherconf.set('libdir', libdir)
|
|
launcherconf.set('pkgdatadir', pkgdatadir)
|
|
-launcherconf.set('gjs', gjs.path())
|
|
+launcherconf.set('gjs', gjs)
|
|
|
|
configure_file(
|
|
input: prgname + '.in',
|
|
diff --git a/subprojects/extensions-app/meson.build b/subprojects/extensions-app/meson.build
|
|
index 4acd94c..c6bdd5f 100644
|
|
--- a/subprojects/extensions-app/meson.build
|
|
+++ b/subprojects/extensions-app/meson.build
|
|
@@ -35,7 +35,7 @@ localedir = join_paths(datadir, 'locale')
|
|
metainfodir = join_paths(datadir, 'metainfo')
|
|
servicedir = join_paths(datadir, 'dbus-1', 'services')
|
|
|
|
-gjs = find_program('gjs')
|
|
+gjs = '/usr/bin/gjs'
|
|
appstream_util = find_program('appstream-util', required: false)
|
|
desktop_file_validate = find_program('desktop-file-validate', required: false)
|
|
|