Bruce Leidl
3db0a6b032
poky: Upgrade to Yocto 4.1 Langdale meta-citadel/recipes-kernel: citadel-kernel 5.19.9 -> 6.0.8 meta-citadel/recipes-sway: sway 1.5.1 -> 1.7 (meta-wayland) wlroots 0.12.0 -> 0.15.1 (meta-wayland) meta-gnome/recipes-connectivity: iwd 1.27 -> 1.30 (meta-oe) modemmanager 1.18.2 -> 1.18.6 (meta-oe) networkmanager 1.36.2 -> 1.40.0 (meta-oe) meta-gnome/recipes-freedesktop: libgusb 0.3.7 -> 0.3.10 (meta-oe) meta-gnome/recipes-gnome: adwaita-icon-theme 42 -> 43 (oe-core) geocode-glib 3.26.2 -> 3.26.4 (meta-oe) gjs 1.72.0 -> 1.73.2 (meta-oe) gnome-bluetooth 42.0 -> 42.4 (meta-oe) gnome-control-center 42.1 -> 43.0 gnome-desktop 42.1 -> 43.rc gnome-settings-daemon 42.1 -> 43.0 gnome-shell 42.1 -> 43.0 gsettings-desktop-schema 41.0 -> 43.0 gtk4 4.6.4 -> 4.6.7 (meta-oe) gvfs 1.50.0 -> 1.50.2 (meta-oe) libadwaita 1.1.1 -> 1.2.0 (meta-oe) libgee 0.20.4 -> 0.20.6 (meta-oe) mutter 42.1 -> 43.0 rest 0.8.1 -> 0.9.0 (meta-oe) meta-gnome/recipes-support: ell 0.50 -> 0.53 (poky) exiv2 0.26 -> 0.27.3 (meta-oe) graphene 1.10.2 -> 1.10.8 (meta-oe) gsound 1.0.2 -> 1.0.3 (meta-oe) icu_71.1 (removed from meta-gnome because this version is in poky) jansson 2.12 -> 2.14 (meta-oe) lcms 2.9 -> 2.14 (meta-oe) libdvdread 6.1.1 -> 6.1.3 (meta-oe) libndp 1.6 -> 1.8 (meta-oe) mozjs 91.8.0 -> 102.3.0 power-profiles-daemon 0.12 (new-recipe)
50 lines
1.5 KiB
BlitzBasic
50 lines
1.5 KiB
BlitzBasic
SUMMARY = "A modular Wayland compositor library"
|
|
DESCRIPTION = "Pluggable, composable, unopinionated modules for building a \
|
|
Wayland compositor; or about 50,000 lines of code you were \
|
|
going to write anyway."
|
|
HOMEPAGE = "https://gitlab.freedesktop.org/wlroots"
|
|
BUGTRACKER = "https://gitlab.freedesktop.org/wlroots/wlroots/-/issues"
|
|
SECTION = "graphics"
|
|
LICENSE = "MIT"
|
|
|
|
LIC_FILES_CHKSUM = "file://LICENSE;md5=7578fad101710ea2d289ff5411f1b818"
|
|
|
|
REQUIRED_DISTRO_FEATURES = "wayland"
|
|
|
|
DEPENDS += " \
|
|
libdrm \
|
|
libxkbcommon \
|
|
pixman \
|
|
seatd \
|
|
wayland \
|
|
wayland-native \
|
|
wayland-protocols \
|
|
"
|
|
|
|
PACKAGECONFIG[examples] = "-Dexamples=true,-Dexamples=false,libpng ffmpeg"
|
|
PACKAGECONFIG[opengl] = ",,virtual/egl virtual/libgles2"
|
|
PACKAGECONFIG[gbm] = ",,virtual/libgbm"
|
|
PACKAGECONFIG[libinput] = ",,libinput"
|
|
PACKAGECONFIG[systemd] = ",,systemd"
|
|
PACKAGECONFIG[sysvinit] = ",,eudev elogind"
|
|
PACKAGECONFIG[vulkan] = ",,vulkan-loader vulkan-headers glslang-native"
|
|
PACKAGECONFIG[x11] = ",,xcb-util-renderutil"
|
|
PACKAGECONFIG[xwayland] = "-Dxwayland=enabled,-Dxwayland=disabled,xwayland xcb-util-wm,xwayland"
|
|
|
|
PACKAGECONFIG ?= " \
|
|
${@bb.utils.filter('DISTRO_FEATURES', 'systemd sysvinit vulkan x11 xwayland opengl', d)} \
|
|
libinput \
|
|
"
|
|
|
|
SRC_URI = "git://gitlab.freedesktop.org/wlroots/wlroots.git;branch=master;protocol=https"
|
|
SRCREV = "a773231c42812e56c5966fc6a035aa9c6108175a"
|
|
PV = "0.15.1"
|
|
|
|
S = "${WORKDIR}/git"
|
|
|
|
inherit meson pkgconfig features_check
|
|
|
|
EXTRA_OEMESON += "--buildtype release"
|
|
|
|
BBCLASSEXTEND = ""
|