citadel/meta-citadel/recipes-sway/sway/sway_1.7.bb
Bruce Leidl e20e601129 Upgrade to GNOME 45
Updated Recipes:

  gcr4                      3.92   -> 4.0.0
  geoclue                   2.5.7  -> 2.7.0
  gjs                       1.73.2 -> 1.77.90
  gnome-backgrounds         42.0   -> 45.0
  gnome-control-center      43.0   -> 45.0
  gnome-desktop             43.rc  -> 44.0
  gsettings-desktop-schema  43.0   -> 45.0
  libblockdev               2.26   -> 2.28
  libgweather4              4.0.0  -> 4.2.0
  libnma                    1.8.38 -> 1.10.6
  mozjs                     102    -> 115
  nss                       3.64   -> 3.74
  ovmf                      202205 -> 202211

New recipes:

  appstream                 0.16.3
  libei                     1.1.0
  libxmlb                   0.3.14
  tecla                     45.0
  webm/libvpx               1.13

Recipes updated to replace poky recipes with insufficient version:

  glib-2.0                  2.78.0
  gtk+/gtk+3                3.24.38
  gtk+/gtk4                 4.12.1
  icu                       73_2
  wayland/wayland           1.22.0
  wayland/wayland-protocols 1.32
  wayland/libinput          1.24.0
  libadwaita                1.4.0
2023-09-29 12:46:16 -04:00

89 lines
2.2 KiB
BlitzBasic

SUMMARY = "A Wayland WM"
HOMEPAGE = "https://github.com/swaywm/sway"
BUGTRACKER = "https://github.com/swaywm/sway/issues"
SECTION = "graphics"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://LICENSE;md5=dfc67e5b1fa10ebb4b70eb0c0ca67bea"
REQUIRED_DISTRO_FEATURES = "wayland"
DEPENDS += " \
wlroots \
cairo \
libevdev \
json-c \
libdrm \
libinput \
libxkbcommon \
pango \
pcre2 \
pixman \
virtual/libgles2 \
wayland \
wayland-native \
wayland-protocols \
"
#RDEPENDS:${PN} ?= "swaybg python3 python-i3ipc"
#RRECOMMENDS:${PN} ?= " \
# foot \
# jq \
# grim \
# slurp \
# wl-clipboard \
#"
SRC_URI = "git://github.com/swaywm/sway.git;protocol=https;branch=master \
file://config \
file://0001-Reinstate-wayland-0-as-starting-display-socket-for-C.patch \
file://0001-Added-case-for-libinput-custom-accel-profile.patch \
"
SRCREV = "9d99bb956fea8922f8e0196d67eabbd510c53f1f"
PV = "1.7"
S = "${WORKDIR}/git"
inherit meson pkgconfig features_check
PACKAGECONFIG[basu] = "-Dsd-bus-provider=basu,,basu"
PACKAGECONFIG[default-wallpaper] = "-Ddefault-wallpaper=true,-Ddefault-wallpaper=false"
PACKAGECONFIG[elogind] = "-Dsd-bus-provider=libelogind,,elogind"
PACKAGECONFIG[gdk-pixbuf] = "-Dgdk-pixbuf=enabled,-Dgdk-pixbuf=disabled,gdk-pixbuf"
PACKAGECONFIG[swaybar] = "-Dswaybar=true,-Dswaybar=false"
PACKAGECONFIG[swaynag] = "-Dswaynag=true,-Dswaynag=false"
PACKAGECONFIG[systemd] = "-Dsd-bus-provider=libsystemd,,systemd"
PACKAGECONFIG[tray] = "-Dtray=enabled,-Dtray=disabled"
PACKAGECONFIG[xwayland] = "-Dxwayland=enabled,-Dxwayland=disabled,libxcb"
PACKAGECONFIG ?= " \
${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)} \
gdk-pixbuf \
"
# Reproducibility issue. Fix me!
CFLAGS:append = " -Wno-error=date-time"
EXTRA_OEMESON += "--buildtype release"
#do_install:append() {
# install -m 755 ${S}/contrib/grimshot ${D}${bindir}
# install -m 755 ${S}/contrib/autoname-workspaces.py ${D}${bindir}
# install -m 755 ${S}/contrib/inactive-windows-transparency.py ${D}${bindir}
#}
FILES:${PN} += "\
${datadir}/wayland-sessions/sway.desktop \
"
do_install:append() {
rm ${D}${sysconfdir}/sway/config
install -m 644 ${WORKDIR}/config ${D}${sysconfdir}/sway/config
}
FILES:${PN}:append = " \
${datadir} \
"
BBCLASSEXTEND = ""