Bruce Leidl
be34ea65f3
- removed layers meta-rust and meta-clang - added new dependencies to Makefile - changed override syntax across all recipe files - updated conf files from hardknott to kirkstone - SRC_URI git URLS fixed to always include branch and protocol - LICENSE fields updated with new naming convention - updated citadel-tools dependencies - upgraded mozjs to mozjs-91 No longer needed because poky includes newer version (or new enough): - glib-2.0 - libgudev - xorgproto - libxfixes - libinput - wayland-protocols - vte
27 lines
682 B
BlitzBasic
27 lines
682 B
BlitzBasic
require wireguard.inc
|
|
|
|
SRCREV = "622408872fd6f3a58e98e88d39d30e98968314fa"
|
|
SRC_URI = "git://git.zx2c4.com/wireguard-tools;branch=master"
|
|
|
|
inherit bash-completion systemd pkgconfig
|
|
|
|
DEPENDS += "libmnl"
|
|
|
|
do_install () {
|
|
oe_runmake DESTDIR="${D}" PREFIX="${prefix}" SYSCONFDIR="${sysconfdir}" \
|
|
SYSTEMDUNITDIR="${systemd_system_unitdir}" \
|
|
WITH_SYSTEMDUNITS=${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'yes', '', d)} \
|
|
WITH_BASHCOMPLETION=yes \
|
|
WITH_WGQUICK=yes \
|
|
install
|
|
}
|
|
|
|
FILES:${PN} = " \
|
|
${sysconfdir} \
|
|
${systemd_system_unitdir} \
|
|
${bindir} \
|
|
"
|
|
|
|
RDEPENDS:${PN} = "bash"
|
|
RRECOMMENDS:${PN} = "kernel-module-wireguard"
|