Bruce Leidl
be34ea65f3
- removed layers meta-rust and meta-clang - added new dependencies to Makefile - changed override syntax across all recipe files - updated conf files from hardknott to kirkstone - SRC_URI git URLS fixed to always include branch and protocol - LICENSE fields updated with new naming convention - updated citadel-tools dependencies - upgraded mozjs to mozjs-91 No longer needed because poky includes newer version (or new enough): - glib-2.0 - libgudev - xorgproto - libxfixes - libinput - wayland-protocols - vte
35 lines
1.1 KiB
BlitzBasic
35 lines
1.1 KiB
BlitzBasic
require wireguard.inc
|
|
|
|
SRCREV = "122f06bfd8fc7b06a0899fa9adc4ce8e06900d98"
|
|
|
|
SRC_URI = "git://git.zx2c4.com/wireguard-linux-compat;branch=master"
|
|
|
|
inherit module kernel-module-split
|
|
|
|
DEPENDS = "virtual/kernel libmnl"
|
|
|
|
# This module requires Linux 3.10 higher and several networking related
|
|
# configuration options. For exact kernel requirements visit:
|
|
# https://www.wireguard.io/install/#kernel-requirements
|
|
|
|
EXTRA_OEMAKE:append = " \
|
|
KERNELDIR=${STAGING_KERNEL_DIR} \
|
|
"
|
|
|
|
MAKE_TARGETS = "module"
|
|
|
|
RRECOMMENDS:${PN} = "kernel-module-xt-hashlimit"
|
|
MODULE_NAME = "wireguard"
|
|
|
|
module_do_install() {
|
|
install -d ${D}${nonarch_base_libdir}/modules/${KERNEL_VERSION}/kernel/${MODULE_NAME}
|
|
install -m 0644 ${MODULE_NAME}.ko \
|
|
${D}${nonarch_base_libdir}/modules/${KERNEL_VERSION}/kernel/${MODULE_NAME}/${MODULE_NAME}.ko
|
|
}
|
|
|
|
# WireGuard has been merged into Linux kernel >= 5.6 and therefore this compatibility module is no longer required.
|
|
# OE-core post dunfell has moved to use kernel 5.8 which now means we cant build this module in world builds
|
|
# for reference machines e.g. qemu
|
|
EXCLUDE_FROM_WORLD = "1"
|
|
|